Forum Search:
Forum.Brain-Cluster.com: Brain Cluster Technical Forum
Ultimate forum for Technical Discussions

Home » Microsoft » Windows Server » Active Directory » Unable to install Active Directory Management Gateway Service (ADMGS) on Server 2008
Unable to install Active Directory Management Gateway Service (ADMGS) on Server 2008 [message #161340] Wed, 23 September 2009 09:20 Go to next message
ssg31415926  is currently offline ssg31415926  United Kingdom
Messages: 3
Registered: September 2009
Junior Member
I cannot install the Active Directory Management Gateway Service
(ADMGS) on my Server 2008 Domain Controllers - I was originally trying
to install it on an SP2 machine and it failed so I tried using the
patch instead of SP2 and that failed as well.

I have two Windows Server 2008 Domain Controllers. Both are x64
servers. Both have .NET 3.5 SP1 installed on them. One has Service
Pack 2 installed and the other has the hotfix from 967574 installed.
Both servers were rebooted after the installed of each of the required
updates.

I have attempted to install Windows6.0-KB968934-x64.msu on both and
get the same error:

"The update does not apply to your system".

I'm rather puzzled. Has anyone seen anything similar?
Re: Unable to install Active Directory Management Gateway Service (ADMGS) on Server 2008 [message #161351 is a reply to message #161340] Wed, 23 September 2009 14:07 Go to previous messageGo to next message
Meinolf Weber MVP-DS  is currently offline Meinolf Weber MVP-DS  Germany
Messages: 129
Registered: July 2009
Senior Member
Hello ssg31415926,

Make sure to follow:

"So that you can successfully install the Active Directory Management Gateway
Service, the following components must be running on your server:
Active Directory Domain Services (AD DS) or AD LDS server roles: you can
install Active Directory Management Gateway Service only if you promote your
server to domain controller by running Dcpromo.exe or if you create an AD
LDS instance (or ADAM instance) on this server.

..NET Framework 3.5 with Service Pack 1 (SP1)

Software updates:

For Windows Server 2003-based computers and Windows Server 2008-based computers,
you must download and install the hotfix that is described in article 969166
in the Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=153321).

Note: You can install this hotfix only when .NET Framework 3.5 SP1 is
running on your computer.

For Windows Server 2003 R2 SP2 and Windows Server 2003 SP2, you must download
and install the hotfix that is described in article 969429 in the Microsoft
Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152375).

For Windows Server 2008, you must download and install the hotfix that is
described in article 967574 in the Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152377).

Note: You do not have to install this hotfix if your server is running
Windows Server 2008 SP2 because this hotfix is built into the SP2 version
of Windows Server 2008. "
From: http://www.microsoft.com/downloads/details.aspx?displaylang= en&FamilyID=008940c6-0296-4597-be3e-1d24c1cf0dda

http://technet.microsoft.com/en-us/library/dd391908(WS.10).aspx

Best regards

Meinolf Weber
Disclaimer: This posting is provided "AS IS" with no warranties, and confers
no rights.
** Please do NOT email, only reply to Newsgroups
** HELP us help YOU!!! http://www.blakjak.demon.co.uk/mul_crss.htm


> I cannot install the Active Directory Management Gateway Service
> (ADMGS) on my Server 2008 Domain Controllers - I was originally trying
> to install it on an SP2 machine and it failed so I tried using the
> patch instead of SP2 and that failed as well.
>
> I have two Windows Server 2008 Domain Controllers. Both are x64
> servers. Both have .NET 3.5 SP1 installed on them. One has Service
> Pack 2 installed and the other has the hotfix from 967574 installed.
> Both servers were rebooted after the installed of each of the required
> updates.
>
> I have attempted to install Windows6.0-KB968934-x64.msu on both and
> get the same error:
>
> "The update does not apply to your system".
>
> I'm rather puzzled. Has anyone seen anything similar?
>
Re: Unable to install Active Directory Management Gateway Service (ADMGS) on Server 2008 [message #161388 is a reply to message #161351] Thu, 24 September 2009 12:10 Go to previous messageGo to next message
ssg31415926  is currently offline ssg31415926  United Kingdom
Messages: 3
Registered: September 2009
Junior Member
As I said, they're domain controllers, so they're running Active
Directory Domain Services, so that's the first qualfication.

They're running .NET Framework 3.5 SP1, so that's the second.

They're both server 2008. One has 967574 and the other has SP2, so
that's the third.

So, unless I've missed something, my DCs meet all of the
qualifications. Except that it seems they don't. What else does the
installer check for?

On Sep 23, 9:07 pm, Meinolf Weber [MVP-DS] wrote:
> Hello ssg31415926,
>
> Make sure to follow:
>
> "So that you can successfully install the Active Directory Management Gateway
> Service, the following components must be running on your server:
> Active Directory Domain Services (AD DS) or AD LDS server roles: you can
> install Active Directory Management Gateway Service only if you promote your
> server to domain controller by running Dcpromo.exe or if you create an AD
> LDS instance (or ADAM instance) on this server.
>
> .NET Framework 3.5 with Service Pack 1 (SP1)
>
> Software updates:
>
> For Windows Server 2003-based computers and Windows Server 2008-based computers,
> you must download and install the hotfix that is described in article 969166
> in the Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=153321).
>
> Note:    You can install this hotfix only when .NET Framework 3.5 SP1 is
> running on your computer.
>
> For Windows Server 2003 R2 SP2 and Windows Server 2003 SP2, you must download
> and install the hotfix that is described in article 969429 in the Microsoft
> Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152375).
>
> For Windows Server 2008, you must download and install the hotfix that is
> described in article 967574 in the Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152377).
>
> Note:    You do not have to install this hotfix if your server is running
> Windows Server 2008 SP2 because this hotfix is built into the SP2 version
> of Windows Server 2008. "
> From:http://www.microsoft.com/downloads/details.aspx?display lang=en&Family...
>
> http://technet.microsoft.com/en-us/library/dd391908(WS.10).aspx
>
> Best regards
>
> Meinolf Weber
> Disclaimer: This posting is provided "AS IS" with no warranties, and confers
> no rights.
> ** Please do NOT email, only reply to Newsgroups
> ** HELP us help YOU!!!http://www.blakjak.demon.co.uk/mul_crss.htm
>
> > I cannot install the Active Directory Management Gateway Service
> > (ADMGS) on my Server 2008 Domain Controllers - I was originally trying
> > to install it on an SP2 machine and it failed so I tried using the
> > patch instead of SP2 and that failed as well.
>
> > I have two Windows Server 2008 Domain Controllers.  Both are x64
> > servers.  Both have .NET 3.5 SP1 installed on them.  One has Service
> > Pack 2 installed and the other has the hotfix from 967574 installed.
> > Both servers were rebooted after the installed of each of the required
> > updates.
>
> > I have attempted to install Windows6.0-KB968934-x64.msu on both and
> > get the same error:
>
> > "The update does not apply to your system".
>
> > I'm rather puzzled.  Has anyone seen anything similar?
Re: Unable to install Active Directory Management Gateway Service [message #161502 is a reply to message #161388] Tue, 29 September 2009 10:01 Go to previous messageGo to next message
Shawn Hayes  is currently offline Shawn Hayes
Messages: 3
Registered: September 2009
Junior Member
I have the same issue...exactly. Any resolution yet?
--
Shawn


"ssg31415926" wrote:

> As I said, they're domain controllers, so they're running Active
> Directory Domain Services, so that's the first qualfication.
>
> They're running .NET Framework 3.5 SP1, so that's the second.
>
> They're both server 2008. One has 967574 and the other has SP2, so
> that's the third.
>
> So, unless I've missed something, my DCs meet all of the
> qualifications. Except that it seems they don't. What else does the
> installer check for?
>
> On Sep 23, 9:07 pm, Meinolf Weber [MVP-DS] wrote:
> > Hello ssg31415926,
> >
> > Make sure to follow:
> >
> > "So that you can successfully install the Active Directory Management Gateway
> > Service, the following components must be running on your server:
> > Active Directory Domain Services (AD DS) or AD LDS server roles: you can
> > install Active Directory Management Gateway Service only if you promote your
> > server to domain controller by running Dcpromo.exe or if you create an AD
> > LDS instance (or ADAM instance) on this server.
> >
> > .NET Framework 3.5 with Service Pack 1 (SP1)
> >
> > Software updates:
> >
> > For Windows Server 2003-based computers and Windows Server 2008-based computers,
> > you must download and install the hotfix that is described in article 969166
> > in the Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=153321).
> >
> > Note: You can install this hotfix only when .NET Framework 3.5 SP1 is
> > running on your computer.
> >
> > For Windows Server 2003 R2 SP2 and Windows Server 2003 SP2, you must download
> > and install the hotfix that is described in article 969429 in the Microsoft
> > Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152375).
> >
> > For Windows Server 2008, you must download and install the hotfix that is
> > described in article 967574 in the Microsoft Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152377).
> >
> > Note: You do not have to install this hotfix if your server is running
> > Windows Server 2008 SP2 because this hotfix is built into the SP2 version
> > of Windows Server 2008. "
> > From:http://www.microsoft.com/downloads/details.aspx?display lang=en&Family...
> >
> > http://technet.microsoft.com/en-us/library/dd391908(WS.10).aspx
> >
> > Best regards
> >
> > Meinolf Weber
> > Disclaimer: This posting is provided "AS IS" with no warranties, and confers
> > no rights.
> > ** Please do NOT email, only reply to Newsgroups
> > ** HELP us help YOU!!!http://www.blakjak.demon.co.uk/mul_crss.htm
> >
> > > I cannot install the Active Directory Management Gateway Service
> > > (ADMGS) on my Server 2008 Domain Controllers - I was originally trying
> > > to install it on an SP2 machine and it failed so I tried using the
> > > patch instead of SP2 and that failed as well.
> >
> > > I have two Windows Server 2008 Domain Controllers. Both are x64
> > > servers. Both have .NET 3.5 SP1 installed on them. One has Service
> > > Pack 2 installed and the other has the hotfix from 967574 installed.
> > > Both servers were rebooted after the installed of each of the required
> > > updates.
> >
> > > I have attempted to install Windows6.0-KB968934-x64.msu on both and
> > > get the same error:
> >
> > > "The update does not apply to your system".
> >
> > > I'm rather puzzled. Has anyone seen anything similar?
>
>
Re: Unable to install Active Directory Management Gateway Service [message #161507 is a reply to message #161502] Tue, 29 September 2009 12:15 Go to previous messageGo to next message
Lee Flight  is currently offline Lee Flight  United Kingdom
Messages: 392
Registered: July 2009
Senior Member
Hi,

note the:

"For Windows Server 2003–based computers and
Windows Server 2008–based computers, you must
download and install the hotfix that is described
in article 969166 in the Microsoft Knowledge Base
(http://go.microsoft.com/fwlink/?LinkId=153321).

Note: You can install this hotfix only when
.NET Framework 3.5 SP1 is running on your computer. "

from the download page. ADWS has a pre-req check for this hotfix
and will not install without it being in place and fails with the
message you give below when the hotfix is absent.

Lee Flight

"Shawn Hayes" <ShawnHayes@discussions.microsoft.com> wrote in message
news:2E05DC09-1D79-4C03-90D9-3C1905C701AA@microsoft.com...
> I have the same issue...exactly. Any resolution yet?
> --
> Shawn
>
>
> "ssg31415926" wrote:
>
>> As I said, they're domain controllers, so they're running Active
>> Directory Domain Services, so that's the first qualfication.
>>
>> They're running .NET Framework 3.5 SP1, so that's the second.
>>
>> They're both server 2008. One has 967574 and the other has SP2, so
>> that's the third.
>>
>> So, unless I've missed something, my DCs meet all of the
>> qualifications. Except that it seems they don't. What else does the
>> installer check for?
>>
>> On Sep 23, 9:07 pm, Meinolf Weber [MVP-DS] wrote:
>> > Hello ssg31415926,
>> >
>> > Make sure to follow:
>> >
>> > "So that you can successfully install the Active Directory Management
>> > Gateway
>> > Service, the following components must be running on your server:
>> > Active Directory Domain Services (AD DS) or AD LDS server roles: you
>> > can
>> > install Active Directory Management Gateway Service only if you promote
>> > your
>> > server to domain controller by running Dcpromo.exe or if you create an
>> > AD
>> > LDS instance (or ADAM instance) on this server.
>> >
>> > .NET Framework 3.5 with Service Pack 1 (SP1)
>> >
>> > Software updates:
>> >
>> > For Windows Server 2003-based computers and Windows Server 2008-based
>> > computers,
>> > you must download and install the hotfix that is described in article
>> > 969166
>> > in the Microsoft Knowledge Base
>> > (http://go.microsoft.com/fwlink/?LinkId=153321).
>> >
>> > Note: You can install this hotfix only when .NET Framework 3.5 SP1
>> > is
>> > running on your computer.
>> >
>> > For Windows Server 2003 R2 SP2 and Windows Server 2003 SP2, you must
>> > download
>> > and install the hotfix that is described in article 969429 in the
>> > Microsoft
>> > Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152375).
>> >
>> > For Windows Server 2008, you must download and install the hotfix that
>> > is
>> > described in article 967574 in the Microsoft Knowledge Base
>> > (http://go.microsoft.com/fwlink/?LinkId=152377).
>> >
>> > Note: You do not have to install this hotfix if your server is
>> > running
>> > Windows Server 2008 SP2 because this hotfix is built into the SP2
>> > version
>> > of Windows Server 2008. "
>> > From:http://www.microsoft.com/downloads/details.aspx?display lang=en&Family...
>> >
>> > http://technet.microsoft.com/en-us/library/dd391908(WS.10).aspx
>> >
>> > Best regards
>> >
>> > Meinolf Weber
>> > Disclaimer: This posting is provided "AS IS" with no warranties, and
>> > confers
>> > no rights.
>> > ** Please do NOT email, only reply to Newsgroups
>> > ** HELP us help YOU!!!http://www.blakjak.demon.co.uk/mul_crss.htm
>> >
>> > > I cannot install the Active Directory Management Gateway Service
>> > > (ADMGS) on my Server 2008 Domain Controllers - I was originally
>> > > trying
>> > > to install it on an SP2 machine and it failed so I tried using the
>> > > patch instead of SP2 and that failed as well.
>> >
>> > > I have two Windows Server 2008 Domain Controllers. Both are x64
>> > > servers. Both have .NET 3.5 SP1 installed on them. One has Service
>> > > Pack 2 installed and the other has the hotfix from 967574 installed.
>> > > Both servers were rebooted after the installed of each of the
>> > > required
>> > > updates.
>> >
>> > > I have attempted to install Windows6.0-KB968934-x64.msu on both and
>> > > get the same error:
>> >
>> > > "The update does not apply to your system".
>> >
>> > > I'm rather puzzled. Has anyone seen anything similar?
>>
>>
Re: Unable to install Active Directory Management Gateway Service [message #161509 is a reply to message #161507] Tue, 29 September 2009 12:28 Go to previous messageGo to next message
Shawn Hayes  is currently offline Shawn Hayes
Messages: 3
Registered: September 2009
Junior Member
Lee,

Thanks for trying. All of my DC's are 2008 SP2.... 2008 SP2 is said to
have the hotfix in the SP.... so all prerequistes are met.

Shawn

"Lee Flight" wrote:

> Hi,
>
> note the:
>
> "For Windows Server 2003–based computers and
> Windows Server 2008–based computers, you must
> download and install the hotfix that is described
> in article 969166 in the Microsoft Knowledge Base
> (http://go.microsoft.com/fwlink/?LinkId=153321).
>
> Note: You can install this hotfix only when
> .NET Framework 3.5 SP1 is running on your computer. "
>
> from the download page. ADWS has a pre-req check for this hotfix
> and will not install without it being in place and fails with the
> message you give below when the hotfix is absent.
>
> Lee Flight
>
> "Shawn Hayes" <ShawnHayes@discussions.microsoft.com> wrote in message
> news:2E05DC09-1D79-4C03-90D9-3C1905C701AA@microsoft.com...
> > I have the same issue...exactly. Any resolution yet?
> > --
> > Shawn
> >
> >
> > "ssg31415926" wrote:
> >
> >> As I said, they're domain controllers, so they're running Active
> >> Directory Domain Services, so that's the first qualfication.
> >>
> >> They're running .NET Framework 3.5 SP1, so that's the second.
> >>
> >> They're both server 2008. One has 967574 and the other has SP2, so
> >> that's the third.
> >>
> >> So, unless I've missed something, my DCs meet all of the
> >> qualifications. Except that it seems they don't. What else does the
> >> installer check for?
> >>
> >> On Sep 23, 9:07 pm, Meinolf Weber [MVP-DS] wrote:
> >> > Hello ssg31415926,
> >> >
> >> > Make sure to follow:
> >> >
> >> > "So that you can successfully install the Active Directory Management
> >> > Gateway
> >> > Service, the following components must be running on your server:
> >> > Active Directory Domain Services (AD DS) or AD LDS server roles: you
> >> > can
> >> > install Active Directory Management Gateway Service only if you promote
> >> > your
> >> > server to domain controller by running Dcpromo.exe or if you create an
> >> > AD
> >> > LDS instance (or ADAM instance) on this server.
> >> >
> >> > .NET Framework 3.5 with Service Pack 1 (SP1)
> >> >
> >> > Software updates:
> >> >
> >> > For Windows Server 2003-based computers and Windows Server 2008-based
> >> > computers,
> >> > you must download and install the hotfix that is described in article
> >> > 969166
> >> > in the Microsoft Knowledge Base
> >> > (http://go.microsoft.com/fwlink/?LinkId=153321).
> >> >
> >> > Note: You can install this hotfix only when .NET Framework 3.5 SP1
> >> > is
> >> > running on your computer.
> >> >
> >> > For Windows Server 2003 R2 SP2 and Windows Server 2003 SP2, you must
> >> > download
> >> > and install the hotfix that is described in article 969429 in the
> >> > Microsoft
> >> > Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152375).
> >> >
> >> > For Windows Server 2008, you must download and install the hotfix that
> >> > is
> >> > described in article 967574 in the Microsoft Knowledge Base
> >> > (http://go.microsoft.com/fwlink/?LinkId=152377).
> >> >
> >> > Note: You do not have to install this hotfix if your server is
> >> > running
> >> > Windows Server 2008 SP2 because this hotfix is built into the SP2
> >> > version
> >> > of Windows Server 2008. "
> >> > From:http://www.microsoft.com/downloads/details.aspx?display lang=en&Family...
> >> >
> >> > http://technet.microsoft.com/en-us/library/dd391908(WS.10).aspx
> >> >
> >> > Best regards
> >> >
> >> > Meinolf Weber
> >> > Disclaimer: This posting is provided "AS IS" with no warranties, and
> >> > confers
> >> > no rights.
> >> > ** Please do NOT email, only reply to Newsgroups
> >> > ** HELP us help YOU!!!http://www.blakjak.demon.co.uk/mul_crss.htm
> >> >
> >> > > I cannot install the Active Directory Management Gateway Service
> >> > > (ADMGS) on my Server 2008 Domain Controllers - I was originally
> >> > > trying
> >> > > to install it on an SP2 machine and it failed so I tried using the
> >> > > patch instead of SP2 and that failed as well.
> >> >
> >> > > I have two Windows Server 2008 Domain Controllers. Both are x64
> >> > > servers. Both have .NET 3.5 SP1 installed on them. One has Service
> >> > > Pack 2 installed and the other has the hotfix from 967574 installed.
> >> > > Both servers were rebooted after the installed of each of the
> >> > > required
> >> > > updates.
> >> >
> >> > > I have attempted to install Windows6.0-KB968934-x64.msu on both and
> >> > > get the same error:
> >> >
> >> > > "The update does not apply to your system".
> >> >
> >> > > I'm rather puzzled. Has anyone seen anything similar?
> >>
> >>
>
Re: Unable to install Active Directory Management Gateway Service [message #161526 is a reply to message #161509] Tue, 29 September 2009 23:18 Go to previous messageGo to next message
ssg31415926  is currently offline ssg31415926  United Kingdom
Messages: 3
Registered: September 2009
Junior Member
Lee

Thanks for pointing that out. I was sure I'd done everything so I
went back to the download page and there it was. The page was still
at version 1, so I checked my own downloaded instructions to see if MS
had done a sneaky update but there it was, too. Damn! Having looked
at it again, I think I must've read the first few words of that
paragraph, which mentioned 2003, and skipped it. I guess the guy who
was writing the para knew it was about .net so grouped 2003 and 2008
together - he was thinking from his pov, rather than from ours.

Shawn

I think you might've done the same as me. The hotfix that Lee
referred to is not the one you're referring to. There are two
hotfixes required by ADGWS: one for 2008 and one for .NET 3.5 SP1.
The former is included in 2008 SP2, the latter will be included
in .NET 4.0.

I installed that hotfix, had another go and it worked.

Cheers

On Sep 29, 7:28 pm, Shawn Hayes <Shawn
Ha...@discussions.microsoft.com> wrote:
> Lee,
>
> Thanks for trying.  All of my DC's are 2008 SP2....  2008 SP2 is said to
> have the hotfix in the SP.... so all prerequistes are met.
>
> Shawn
>
> "Lee Flight" wrote:
> > Hi,
>
> > note the:
>
> > "For Windows Server 2003–based computers and
> > Windows Server 2008–based computers, you must
> > download and install the hotfix that is described
> > in article 969166 in the Microsoft Knowledge Base
> > (http://go.microsoft.com/fwlink/?LinkId=153321).
>
> > Note:    You can install this hotfix only when
> >   .NET Framework 3.5 SP1 is running on your computer. "
>
> > from the download page. ADWS has a pre-req check for this hotfix
> > and will not install without it being in place and fails with the
> > message you give below when the hotfix is absent.
>
> > Lee Flight
>
> > "Shawn Hayes" <ShawnHa...@discussions.microsoft.com> wrote in message
> >news:2E05DC09-1D79-4C03-90D9-3C1905C701AA@microsoft.com...
> > > I have the same issue...exactly.  Any resolution yet?
> > > --
> > > Shawn
>
> > > "ssg31415926" wrote:
>
> > >> As I said, they're domain controllers, so they're running Active
> > >> Directory Domain Services, so that's the first qualfication.
>
> > >> They're running .NET Framework 3.5 SP1, so that's the second.
>
> > >> They're both server 2008.  One has 967574 and the other has SP2, so
> > >> that's the third.
>
> > >> So, unless I've missed something, my DCs meet all of the
> > >> qualifications.  Except that it seems they don't.  What else does the
> > >> installer check for?
>
> > >> On Sep 23, 9:07 pm, Meinolf Weber [MVP-DS] wrote:
> > >> > Hello ssg31415926,
>
> > >> > Make sure to follow:
>
> > >> > "So that you can successfully install the Active Directory Management
> > >> > Gateway
> > >> > Service, the following components must be running on your server:
> > >> > Active Directory Domain Services (AD DS) or AD LDS server roles: you
> > >> > can
> > >> > install Active Directory Management Gateway Service only if you promote
> > >> > your
> > >> > server to domain controller by running Dcpromo.exe or if you create an
> > >> > AD
> > >> > LDS instance (or ADAM instance) on this server.
>
> > >> > .NET Framework 3.5 with Service Pack 1 (SP1)
>
> > >> > Software updates:
>
> > >> > For Windows Server 2003-based computers and Windows Server 2008-based
> > >> > computers,
> > >> > you must download and install the hotfix that is described in article
> > >> > 969166
> > >> > in the Microsoft Knowledge Base
> > >> > (http://go.microsoft.com/fwlink/?LinkId=153321).
>
> > >> > Note:    You can install this hotfix only when .NET Framework 3.5 SP1
> > >> > is
> > >> > running on your computer.
>
> > >> > For Windows Server 2003 R2 SP2 and Windows Server 2003 SP2, you must
> > >> > download
> > >> > and install the hotfix that is described in article 969429 in the
> > >> > Microsoft
> > >> > Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152375).
>
> > >> > For Windows Server 2008, you must download and install the hotfix that
> > >> > is
> > >> > described in article 967574 in the Microsoft Knowledge Base
> > >> > (http://go.microsoft.com/fwlink/?LinkId=152377).
>
> > >> > Note:    You do not have to install this hotfix if your server is
> > >> > running
> > >> > Windows Server 2008 SP2 because this hotfix is built into the SP2
> > >> > version
> > >> > of Windows Server 2008. "
> > >> > From:http://www.microsoft.com/downloads/details.aspx?display lang=en&Family...
>
> > >> >http://technet.microsoft.com/en-us/library/dd391908(WS.10).aspx
>
> > >> > Best regards
>
> > >> > Meinolf Weber
> > >> > Disclaimer: This posting is provided "AS IS" with no warranties, and
> > >> > confers
> > >> > no rights.
> > >> > ** Please do NOT email, only reply to Newsgroups
> > >> > ** HELP us help YOU!!!http://www.blakjak.demon.co.uk/mul_crss.htm
>
> > >> > > I cannot install the Active Directory Management Gateway Service
> > >> > > (ADMGS) on my Server 2008 Domain Controllers - I was originally
> > >> > > trying
> > >> > > to install it on an SP2 machine and it failed so I tried using the
> > >> > > patch instead of SP2 and that failed as well.
>
> > >> > > I have two Windows Server 2008 Domain Controllers.  Both are x64
> > >> > > servers.  Both have .NET 3.5 SP1 installed on them.  One has Service
> > >> > > Pack 2 installed and the other has the hotfix from 967574 installed.
> > >> > > Both servers were rebooted after the installed of each of the
> > >> > > required
> > >> > > updates.
>
> > >> > > I have attempted to install Windows6.0-KB968934-x64.msu on both and
> > >> > > get the same error:
>
> > >> > > "The update does not apply to your system".
>
> > >> > > I'm rather puzzled.  Has anyone seen anything similar?
Re: Unable to install Active Directory Management Gateway Service [message #161938 is a reply to message #161526] Fri, 09 October 2009 13:54 Go to previous message
Shawn Hayes  is currently offline Shawn Hayes
Messages: 3
Registered: September 2009
Junior Member
Yep, I am eating Crow. Lee, you were exactly right. Once I read the release
notes again it was plain as day.... All is well

Shawn



"ssg31415926" wrote:

> Lee
>
> Thanks for pointing that out. I was sure I'd done everything so I
> went back to the download page and there it was. The page was still
> at version 1, so I checked my own downloaded instructions to see if MS
> had done a sneaky update but there it was, too. Damn! Having looked
> at it again, I think I must've read the first few words of that
> paragraph, which mentioned 2003, and skipped it. I guess the guy who
> was writing the para knew it was about .net so grouped 2003 and 2008
> together - he was thinking from his pov, rather than from ours.
>
> Shawn
>
> I think you might've done the same as me. The hotfix that Lee
> referred to is not the one you're referring to. There are two
> hotfixes required by ADGWS: one for 2008 and one for .NET 3.5 SP1.
> The former is included in 2008 SP2, the latter will be included
> in .NET 4.0.
>
> I installed that hotfix, had another go and it worked.
>
> Cheers
>
> On Sep 29, 7:28 pm, Shawn Hayes <Shawn
> Ha...@discussions.microsoft.com> wrote:
> > Lee,
> >
> > Thanks for trying. All of my DC's are 2008 SP2.... 2008 SP2 is said to
> > have the hotfix in the SP.... so all prerequistes are met.
> >
> > Shawn
> >
> > "Lee Flight" wrote:
> > > Hi,
> >
> > > note the:
> >
> > > "For Windows Server 2003–based computers and
> > > Windows Server 2008–based computers, you must
> > > download and install the hotfix that is described
> > > in article 969166 in the Microsoft Knowledge Base
> > > (http://go.microsoft.com/fwlink/?LinkId=153321).
> >
> > > Note: You can install this hotfix only when
> > > .NET Framework 3.5 SP1 is running on your computer. "
> >
> > > from the download page. ADWS has a pre-req check for this hotfix
> > > and will not install without it being in place and fails with the
> > > message you give below when the hotfix is absent.
> >
> > > Lee Flight
> >
> > > "Shawn Hayes" <ShawnHa...@discussions.microsoft.com> wrote in message
> > >news:2E05DC09-1D79-4C03-90D9-3C1905C701AA@microsoft.com...
> > > > I have the same issue...exactly. Any resolution yet?
> > > > --
> > > > Shawn
> >
> > > > "ssg31415926" wrote:
> >
> > > >> As I said, they're domain controllers, so they're running Active
> > > >> Directory Domain Services, so that's the first qualfication.
> >
> > > >> They're running .NET Framework 3.5 SP1, so that's the second.
> >
> > > >> They're both server 2008. One has 967574 and the other has SP2, so
> > > >> that's the third.
> >
> > > >> So, unless I've missed something, my DCs meet all of the
> > > >> qualifications. Except that it seems they don't. What else does the
> > > >> installer check for?
> >
> > > >> On Sep 23, 9:07 pm, Meinolf Weber [MVP-DS] wrote:
> > > >> > Hello ssg31415926,
> >
> > > >> > Make sure to follow:
> >
> > > >> > "So that you can successfully install the Active Directory Management
> > > >> > Gateway
> > > >> > Service, the following components must be running on your server:
> > > >> > Active Directory Domain Services (AD DS) or AD LDS server roles: you
> > > >> > can
> > > >> > install Active Directory Management Gateway Service only if you promote
> > > >> > your
> > > >> > server to domain controller by running Dcpromo.exe or if you create an
> > > >> > AD
> > > >> > LDS instance (or ADAM instance) on this server.
> >
> > > >> > .NET Framework 3.5 with Service Pack 1 (SP1)
> >
> > > >> > Software updates:
> >
> > > >> > For Windows Server 2003-based computers and Windows Server 2008-based
> > > >> > computers,
> > > >> > you must download and install the hotfix that is described in article
> > > >> > 969166
> > > >> > in the Microsoft Knowledge Base
> > > >> > (http://go.microsoft.com/fwlink/?LinkId=153321).
> >
> > > >> > Note: You can install this hotfix only when .NET Framework 3.5 SP1
> > > >> > is
> > > >> > running on your computer.
> >
> > > >> > For Windows Server 2003 R2 SP2 and Windows Server 2003 SP2, you must
> > > >> > download
> > > >> > and install the hotfix that is described in article 969429 in the
> > > >> > Microsoft
> > > >> > Knowledge Base (http://go.microsoft.com/fwlink/?LinkId=152375).
> >
> > > >> > For Windows Server 2008, you must download and install the hotfix that
> > > >> > is
> > > >> > described in article 967574 in the Microsoft Knowledge Base
> > > >> > (http://go.microsoft.com/fwlink/?LinkId=152377).
> >
> > > >> > Note: You do not have to install this hotfix if your server is
> > > >> > running
> > > >> > Windows Server 2008 SP2 because this hotfix is built into the SP2
> > > >> > version
> > > >> > of Windows Server 2008. "
> > > >> > From:http://www.microsoft.com/downloads/details.aspx?display lang=en&Family...
> >
> > > >> >http://technet.microsoft.com/en-us/library/dd391908(WS.10).aspx
> >
> > > >> > Best regards
> >
> > > >> > Meinolf Weber
> > > >> > Disclaimer: This posting is provided "AS IS" with no warranties, and
> > > >> > confers
> > > >> > no rights.
> > > >> > ** Please do NOT email, only reply to Newsgroups
> > > >> > ** HELP us help YOU!!!http://www.blakjak.demon.co.uk/mul_crss.htm
> >
> > > >> > > I cannot install the Active Directory Management Gateway Service
> > > >> > > (ADMGS) on my Server 2008 Domain Controllers - I was originally
> > > >> > > trying
> > > >> > > to install it on an SP2 machine and it failed so I tried using the
> > > >> > > patch instead of SP2 and that failed as well.
> >
> > > >> > > I have two Windows Server 2008 Domain Controllers. Both are x64
> > > >> > > servers. Both have .NET 3.5 SP1 installed on them. One has Service
> > > >> > > Pack 2 installed and the other has the hotfix from 967574 installed.
> > > >> > > Both servers were rebooted after the installed of each of the
> > > >> > > required
> > > >> > > updates.
> >
> > > >> > > I have attempted to install Windows6.0-KB968934-x64.msu on both and
> > > >> > > get the same error:
> >
> > > >> > > "The update does not apply to your system".
> >
> > > >> > > I'm rather puzzled. Has anyone seen anything similar?
>
>
Previous Topic:going native questions
Next Topic:Server time on DC time lags 1:30 sec from NTP source?
Goto Forum:
  


Current Time: Tue Jan 16 04:15:39 MST 2018

Total time taken to generate the page: 0.05176 seconds
.:: Contact :: Home ::Sitemap::.

Powered by: FUDforum 3.0.0RC2.
Copyright ©2001-2009 FUDforum Bulletin Board Software